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OrCAD® EnvironmentChapter 1

1. OrCAD Capture 늦게실행되는현상해결방법
2. OrCAD(*.dsn) File더블클릭실행오류해결방법

3. Library 추가할때 Ref.Des 자동으로부여설정방법

Chapter 1 OrCAD® Environment
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Step 1

OrCAD® Environment

1

OrCAD Capture 10.x 버전 Tool이늦게실행되는현상해결방법

10.x 버전의실행속도문제로 9.x버전을사용하는개발자

OrCAD 10.x버전을처음실행할때 1~2분정도시간이걸리는데 ITC 로딩옵션을설정하면
실행속도를향상시킬수있습니다. 

Capture를실행한후 Option > Preferences를실행한다.

Preference 창에서 Miscellaneous로이동한후
Enable Intertool Communication의체크박스를
해제하면된다.

Step 2
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Step 1

OrCAD® Environment

2

Window 탐색기에서 OrCAD(*.dsn) File더블클릭실행오류해결방법

탐색기에서 dsn파일을마우스로더블클릭하면 OrCAD만열리고파일오픈에러가발생하는현상

탐색기폴더옵션의파일형식을변경하여해결할수있습니다.

탐색기 > 도구 >  폴더옵션을실행한다.

파일형식에서 DSN을선택한후 “새로만들기(N)”를실행한다.Step 2
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OrCAD® Environment

파일확장자명에 “DSN”을입력하고 “고급(V)”을실행한다.

연결된파일형식에서현재설치된버전의 Capture를선택한후 “확인”버튼을실행한다.

Step 3

Step 4
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OrCAD® Environment

“DSN”확장명에대한세부정보에서 “변경”을실행하여 “Capture”을선택한후 “확인”을실행한다.

설정이완료되면탐색기에서 dsn파일을더블클릭으로실행할수있다.

Step 5
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OrCAD® Environment

3

Library 복사또는 Library 추가할때 Ref.Des 자동으로부여설정방법

Library 복사또는추가시 Reference가 (?)로되는경우설정방법

Reference가 (?) 또는중복된경우 Netlist생성시오류가발생하므로자동부여로설정하는게바람직하다.

라이브러리복사또는추가할때그림과
같이 Ref가 (?)로되는경우가있다

Example



- 9 -www.intercad.co.kr

Capture를실행한후 Option > Preferences를실행한다.

Preference 창에서 Miscellaneous로이동한후 Automatically reference placed parts의
체크박스를설정하면된다.

OrCAD® Environment

Step 1

Step 2
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OrCAD® LibraryChapter 2

1. Gate 또는 Symbol을여러개로나누어진라이브러리작성방법
2. Library Symbol 복사할때 Pin 번호복사하는방법

3. OrCAD Spreadsheet와 Excel 간복사또는붙여넣기

4. PCB상 Net 연결이필요한모든 Pin의 Symbol Pin작성

5. SOT-xx Package Pin Number 부여방법

6. Alphabet Pin Number형식오류 (Mentor Board Station)

Chapter 2 OrCAD® Library
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1

Gate 또는 Symbol을여러개로나누어진 Library 작성방법

Gate 또는 Multi Symbol은 Netlist 생성을위해서는반드시 Package 형태로제작되어야한다.

만약 Package로제작되지않은경우 Netlist 생성시서로다른부품으로인식하게되므로반드시확인해야한다.

OrCAD® Library

라이브러리를 Open한다음 “View > Package”을실행하면아래와같이현재 Symbol을 Package를
확인할수있다.

Package
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OrCAD® Library

Gate Symbol 제작방법 (Multi Package)

추가할 “*.olb”선택하고마우스오른쪽버튼을
이용하여 “New Part”를실행한다.

Symbol 이름을입력한다.
Part per Pkg에생성할 Symbol 개수를입력한다.
Package Type에 Homogeneous를선택한다.

Package Type
Homogeneous
Multi Package의형상및 Pin Name이동일한경우
Heterogeneous
Homogeneous가아닌 Multi Package

Step 1

Step 2
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Tool Palette를이용하여 Gate Symbol “A”을생성한다.

Symbol “A”를작성한후 “View > Next Part”이용하여다음 Symbol “B”로이동한다.

OrCAD® Library

Homogeneous 
Package Type인경우
Pin-Number를제외한
형상및 Symbol정보는
공통으로사용된다.

Step 3

Step 4
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Symbol “B”에해당하는 Pin Number를기록한다.

OrCAD® Library

Step 4-5와같은방법으로 Symbol “C” “D”을작성한다. 

라이브러리를저장한다음 “View > Package”을실행하여
제작한 Symbol의 Package를확인할수있다.

Step 5

Step 6
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여러개로나누어진 Symbol 제작방법 (Multi Package)

추가할 “*.olb”선택하고마우스오른쪽버튼을
이용하여 “New Part”를실행한다.

OrCAD® Library

Symbol 이름을입력한다.
Part per Pkg에생성할 Symbol 개수를입력한다.
Package Type에 Heterogeneous를선택한다.

Package Type
Homogeneous
Multi Package의형상및 Pin Name이동일한경우
Heterogeneous
Homogeneous가아닌 Multi Package

Step 1

Step 2



- 16 -www.intercad.co.kr

Tool Palette를이용하여 Symbol “A”을작성한다.

Symbol “A”를작성한후 “View > Next Part”이용하여다음 Symbol “B”로이동한다.

OrCAD® Library

Heterogeneous 
Package Type인경우
Symbol의형상및
정보를각각다르게

적용할수있다.

Step 3

Step 4
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Symbol “B”에해당하는 Pin Number를기록한다.

Step 4-5와같은방법으로 Symbol “C”를작성한다. 

라이브러리를저장한다음 “View > Package”을실행하여
제작한 Symbol의 Package를확인할수있다.

OrCAD® Library

Step 5

Step 6
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2

Library Symbol 복사할때 Pin 번호복사하는방법

Library 복사할때 Pin 번호는복사되지않는다.

Library 복사후 Pin 번호를복사하는방법에대하여알아보자.

전체를선택하여 Ctrl+C를이용하여복사한후 Paste할 Symbol에 Ctrl+V하여 Paste하면
복사는되지만 Pin 번호가복사되지않는다.

OrCAD® Library

?

Example
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OrCAD® Library

복사할 Pin을모두선택하고마우스오른쪽버튼을이용하여 “Edit Properties”을실행한다.Step 1
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OrCAD® Library

왼쪽모서리를클릭하여전체영역을선택한다.

“Ctrl+Insert”을이용하여선택한영역을클립보드로복사한다.

Tip Spreadsheet창에서선택한영역을클립보드로복사할때 Ctrl+C가아니라 Ctrl+Insert을
이용해야한다.

Step 2
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OrCAD® Library

Paste할부품의 Pin을모두선택하고마우스오른쪽버튼을이용하여 “Edit Properties”을실행한다.Step 3
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왼쪽모서리를클릭하여전체영역을선택한다.

“Shift+Insert”을이용하여클립보드에복사된정보를붙여넣기하면된다.

Tip Spreadsheet창에서선택한영역에 Paste할경우 Ctrl+V가아니라 Shift+Insert을이용해야
한다.

OrCAD® Library

Step 4
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3

OrCAD Spreadsheet와 Excel Spreadsheet간복사또는붙여넣기

OrCAD Spreadsheet의내용을 Excel Spreadsheet로복사하기
Excel Spreadsheet의내용을 OrCAD Spreadsheet로복사하기

OrCAD Spreadsheet에서복사할셀을선택한후 “Ctrl+Insert”를이용하여복사한후
Excel에서 “Ctrl+V”하여붙여넣기하면된다.

Excel의기능을이용하여입력값을간편하게작성한후 OrCAD로붙여넣기할수있다. 
Library Pin 입력, Schematic Net 입력..

OrCAD® Library

[복사: Ctrl+Insert] [붙여넣기: Ctrl+V]

OrCAD to 
Excel
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OrCAD® Library

Excel에서복사할셀을선택한후 “Ctrl+C”를이용하여복사한후 OrCAD에서
“Shift+Insert”하여붙여넣기하면된다.

[복사: Ctrl+C] [붙여넣기: Shift+Insert]

Tip
OrCAD Spreadsheet의 Copy/Paste 단축키
Copy : Ctrl+Insert
Paste: Shift+Insert

Excel to 
OrCAD
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4

PCB상 Net 연결이되는모든 Pin의 Symbol Pin 작성

PCB Library에 Net가연결되는 Pin이 OrCAD Symbol에표기되지않는경우 Layout에서수작업으로연결해야
하므로 ECO나회로변경내용적용시휴먼에러가발생할수있다.

RCA Jack, BNC, Tack Switch, Regulator, Thermal PAD가있는 SOP/QFP 부품

아래그림의 Regulator 부품의경우 PCB Library 6번 Pin에 GND가연결되어야한다. 

OrCAD® Library

?

[오류]

6번핀누락

[정상]

Example



- 26 -www.intercad.co.kr

OrCAD® Library

아래그림의 Transistor부품의경우 Emitter가 PCB Library의 “1”, “2”번핀에연결되어야한다. 

?

[오류]

2번핀누락

[정상]

Example
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5

SOT-xx Package Pin Number 부여방법

SOT-xx Package는 Layout 담당자와혼선을줄이기위해 Data Sheet에표기된 Pin Number를
기준으로부여한다. 

Diode, TR, FET

OrCAD® Library

Symbol

D1

DIODE
2 3

Data Sheet

Symbol

Data Sheet

Q3
NPN

2
3

1

Diode TR/FET
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Mentor BS(X)

Mentor BS(X)

Q1
FETG

D

S

Mentor BS(X)

6

Alphabet Pin Number 형식오류 (Mentor Board Station) 

일부 Layout 툴(Mentor Board Station)은 Alphabet으로만이루어진 Pin Number를 지원하지않기때문에
Alphabet Pin Number를사용할경우 “Alphabet + Number” 형식으로부여해야한다.

Diode (LED), TR, FET, TCAP(ECAP)…

OrCAD® Library

D1

LED
ANODE CATHODE

D2

LED
A K

D2

LED
A1 K1

D1

LED
1 2

Q?
NPN

B
C

E

Q?
NPN

1
2

3

Q?
NPN

B1
C1

E1

Q?
FET3

1

2

Q1
FETG1

D1

S1

C?
TCAP

+

-
C?
TCAP

P

N C?
TCAP

1

2

C?
TCAP

P1

N1

Mentor BS(X)Diode

FET

TR

ECAP
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OrCAD® SchematicChapter 3

1. Net 또는 Value에사용할수없는문자
2. Ref.Des에사용할수없는문자

3. 서로다른부품에동일한 Value 사용금지

4. 다른페이지와 Net 연결이되지않는현상및원인

5. Global Symbol 사용시 Net Name 확인

6. Symbol Power Pin Net Name 확인

Chapter 2 OrCAD® Schematic
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Net에특수문자사용

XXX

XXX
ADDR{OUT}

UP,DOWNR13 3.9K

SEL*R14 3.9K

RESET?R15 3.9K

DATA 10R16 3.9K

R12 3.9K
Value에특수기호Ω 사용

1

Net 또는 Value에사용할수없는문자

Net에한글/특수문자({},*? Space)/모든특수기호를사용할수없다.
Value에 한글/모든특수기호(Ω℃….)를사용할수없다.
Value의길이가 19자이상은가능한사용하지않는다
19자이상인경우 Netlist 생성시뒷자리가출력되지않는문제가발생한다. 

OrCAD® Schematic

R10

3.9KΩ

Value에특수기호℃사용 Value에한글사용

C3

104/50V/85℃

R11

테스트용

Value 길이가 19자이상

SW2
KHS22C(MODEL SELECTION)

Net에한글사용

테스트
R17 3.9K

Example
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X
Ref.Des에특수문자(.)사용

U3.1
RS485

RO 1

RE
2 DE
3

DI4

GND5

A
6

B
7

VCC 8

올바른 Ref.Des 형식 (문자+N)

O
Ref.Des에한글 사용

X

XX
Ref.Des에특수문자사용

2

Ref.Des에사용할수없는문자

Ref.Des에한글/특수문자({}*,.~-Space)/모든특수기호를사용할수없다.
Ref.Des 번호는가능하면 “문자+Number”형식으로부여한다. (ex) R100
문자로만되어있는경우일부 Layout 툴에서인식하지못하는경우가있다. 

OrCAD® Schematic

Ref.Des에특수문자(-)사용

U-4A
74HC00

1

2
3

ADDR1저항 3.9K

Ref.Des에문자만 사용

X
TEST
TP

U3A
74HC00

1

2
3

C4 104

C5 104

TEST1
TP

R10{1} 3.3K

R,11 3.3K

R 12 3.3K

R13* 3.3K

R14~ 3.3K

Example
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R/L/C NC Value 표기

Foot Print가다른 R/L/C Value 표기

OX X
R10 NC

L11 NC

C3 NC O

3

서로다른부품에동일한 Value 값사용금지

Layout 설계시 Foot Print 입력을동일하게하여오류가발생할수있다.
일반적으로 Layout 설계자는 Value를보고 Foot Print를입력하거나 Netlist파일을수정한다.

Ref.Des Foot Print가다른 R/L/C, AR, VR…

OrCAD® Schematic

R10 NC

L11 NC/L

C3 NC/C

RES와 VR/AR혼용사용시 Value 표기
R10 10K

AR11 10K

VR11 10K

R10 10K

AR11 10K/AR

VR11 10K/VR

X O
R11 10K

R12 10K

R13 10K
2012

1608
R11 10K

R12 10K

R13 10K/2012

Example
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Net명만입력하면다른페이지와연결되지않는다.

4

다른페이지와 Net 연결이되지않는현상및원인

Page와 Page간연결되는 Net는반드시 Offpage/Port를사용해야한다.
Global Symbol에 Offpage/Port를이용하여 Net를연결하면다른페이지와연결되지않는다. 

OrCAD® Schematic

다른페이지와연결해야하는 NET는 Offpage 또는
Port를사용한다.

Netlist
DQ0_XX

Netlist
DQ0

Netlist
DQ0

Netlist
DQ0

Offpage 
(Port)
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Global Symbol에 Offpage를사용하면다른페이지와
연결되지않는다.

OrCAD® Schematic

Global Symbol에 Net를연결할경우 Net명을
이용해야한다.

Netlist 
VCC

Netlist 
VCC_XX

Netlist 
VCC

Netlist 
VCC

Tip Page와 Page간연결되는 Net는반드시 Offpage/Port를사용할것
Global Symbol에 Offpage/Port를사용하지말것

Netlist 
VCC

Global & 
Offpage
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5

Global Symbol 사용시 Net Name 확인

동일한형상의 Symbol이지만실제 Net Name이틀린경우가있다.
Tool Palette 메뉴에서 Power        또는 Ground Symbol       을 Add할때 Net Name을확인해야한다. 

OrCAD® Schematic

아래그림의 GND와 GND_POWER Symbol의경우형상은동일하지만 Name이틀리다. 

Net: 
GND_POWER
를 GND로변경

Net: 
GND

Example
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6

숨겨진 Power Pin의 Net Name 확인

Gate Symbol 또는 Power Pin을사용하는 Symbol의 Net Name은디자인에사용하는 Power Net 
Name으로변경한다.

Gate Symbol외부품은 Power Pin을사용하지않고 Pin으로 Symbol에표기하도록한다. 

OrCAD® Schematic

회로에
사용한

Net로변경

회로에
사용한

Net로변경

Gate 
Symbol
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Symbol의 Power Pin을일반 Pin으로변경

OrCAD® Schematic

Power Pin이숨겨져있는 Symbol

X O

일반
Symbol
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OrCAD® Netlist 생성Chapter 4

1. 중복 Ref.Des 확인방법

2. 중복 Ref.Des 제거방법

3. Ref.Des Reset  및 Update 방법

4. Netlist 생성

5. Netlist 생성시자주발생하는오류및원인

Chapter 1 OrCAD® Environment
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Step 1

OrCAD® Netlist 생성

1

중복 Ref.Des 확인방법

10.3 이전버전에서는중복 Reference 확인방법이없다.

서로다른 Reference가중복으로입력되어있으면 Back Annotate 잘못되며 Layout의
부품배치정보가변경될수있습니다. 

Step 2

모델.DSN 선택 > 마우스메뉴키를실행 > Edit Object Properties를실행한다.

Property Editor창의리스트중 Reference가다르게
중복된경우노란색행으로표시된다.

Hierarchy 구조에서하
나의 Sheet를중복해서
사용할경우중복
Reference가발생한다.
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OrCAD® Netlist 생성

모델.DSN을선택한후 Accessories > Transfer 
Occ. Prop. to Instance > Push Occ. Prop into
Instance를실행한다.

Step 2

Capture를실행한후해당모델을 Open한다.Step 1

중복 Reference 제거방법

2 10.3 이전버전에서는중복 Reference 확인방법이없다.

서로다른 Reference가중복으로입력되어있으면 Back Annotate 잘못되며 Layout의
부품배치정보가변경될수있습니다. 
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OrCAD® Netlist 생성

아래그림과같이설정한후 “OK”버튼을클릭한다.

“확인”버튼을클릭하면서로다른 Reference가삭제된다.

Step 3

Step 4

실행이완료되면 Property Editor창의노란색행이삭제된다.
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OrCAD® Netlist 생성

왼쪽모서리를클릭하여전체영역을선택한다.
“Delete Property”를클릭하여중복 Reference를제거한다.

Step 2

Step 1

Ref.Des 중복제거방법 (Hierarchy 형식)

모델.DSN 선택 > 마우스메뉴키를실행 > Edit Object Properties를실행한다.
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OrCAD® Netlist 생성

3

Ref.Des Reset 하는방법

기존에있는 Reference를 (?)로만드는방법

(?)로되어있는 Reference를자동으로 Numbering 하는방법

Annotate창에서 Action항에 Reset part references
to “?”를체크하고확인을클릭하면 Reference가
(?)로변경된다.

Step 2

Step 1 Capture를실행한후 Tools > Annotate를실행한다.
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OrCAD® Netlist 생성

Annotate창에서 Action항에 ‘Incremental reference update’를체크하고확인을클릭하면
Reference가 Update된다.

Step 2

Ref.Des Update 하는방법

Step 1 Capture를실행한후 Tools > Annotate를실행한다.
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OrCAD® Netlist 생성

해당모델.dsn을선택한후 Tools > 
Create Netlist를실행하거나 아이콘을
실행한다.

Step 1

3

OrCAD Netlist 생성

Layout으로 Net, Comp정보출력을위한 Create Netlist 방법
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OrCAD® Netlist 생성

Create Netlist창에서 Other 탭으로이동한후 Formatters에서 PADS, Mentor Layout에맞는
“xxxx.dll”을선택하고확인버튼을클릭한다.

”확인”버튼을클릭하면 Net, Comp 정보가출력된다.

Step 2

Step 3
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OrCAD® Netlist 생성

4

Netlist 생성시자주발생하는오류및원인

Ref.Des가 (?)로되어있는경우

동일한 Reference가있는경우

Gate Symbol 수정시주의해야할사항

Error Message: Duplicate reference found `xxx`
OrCAD회로도에동일한 Ref.Des가존재할때 Netlist 출력시 Error가발생한다.

동일한 Ref.Des가존재하는경우 Error 처리

동일한 Ref.Des가존재할경우 Reference를재설정한다.

Example 
#1

VCC

R20

3.9K

R20

3.9K

R19

3.9K

해결방법
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OrCAD® Netlist 생성

Error Message: Design is not annotated.
OrCAD회로도에 U(?)로되어있는경우 Netlist를출력해보면 Error가발생된다.

VCC

R20

3.9K

R?

3.9K

R21

120

R22

3.9K

R4

3.9K

Ref.Des가 (?)로되어있는경우 Error로처리

Capture를실행한후 Tools > Annotate를실행한다.
Annotate창에서 Action항에 ‘Incremental reference update’
를체크하고확인을클릭하면 Reference가 Update된다.

Example 
#2

해결방법
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OrCAD® Netlist 생성

[“Update Current”로 Save했을때발생하는 Error Message]

Error Message: Part U6C of type 74HC00_0 is packaged incorrectly with part..  
Gate Symbol을수정후 Save시 “Update Current”로할경우 Source Part를확인해보면
수정된 Part만 Update되며 Netlist생성시 Error가발생한다.

Example 
#3
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OrCAD® Netlist 생성

Error난 Gate Symbol을삭제한다.
Place Part를선택하여 Gate Symbol을다시
삽입한다.

추가한 Gate Symbol 모두선택한후마우스
오른쪽클릭 > Edit Properties를실행하여
“Source Part”이름이모두일치하는지확인한다.

해결방법
Example 

#3
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OrCAD® Layout Interface

OrCAD® Layout InterfaceChapter 5

1. To-Layout (ECO) Process
2. CoWork을이용한 PADS Layout Data 생성
3. OrCAD와 PADS Layout의 Cross Probing
4. PADS Layout 정보 (Ref/Footprint/Loc)를 OrCAD로적용

5. CoWork을이용한 Mentor Layout Data 생성

6. OrCAD와 Mentor Layout의 Cross Probing
7. Mentor Layout 정보 (Ref/Footprint/Loc)를 OrCAD로적용
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Footprint        
확인

CoWork 
Footprint 입력

Footprint        
확인

ECO

1

To-Layout (ECO) Flow

OrCAD Netlist를이용하여 Layout으로적용하는 Flow는아래와같다.

OrCAD® Capture to Layout Interface

OrCAD 
Netlist 출력

Flow

ASCII파일
Footprint 입력

OrCAD 
Footprint입력

OrCAD 
Netlist 출력

Layout         
배치/ 배선

OrCAD 
Netlist 출력

ECO                      
Value 포함

Footprint        
생성

Footprint        
생성

CoWork 
DRC

Error        
해결

Layout         
배치/ 배선

CoWork 
Netlist Check
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2

CoWork을이용한 PADS Layout Data 생성

OrCAD에서출력한 PADS용 Netlist를이용하여 Layout Data를생성할수있다.

CoWork DRC를통하여 OrCAD Netlist에또는 ECO 오류를검사할수있다.

interCAD CoWork을실행한후 Open 아이콘을이용하여 OrCAD dsn 파일을 Open한다.

OrCAD® Capture to Layout Interface

Step 1
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OrCAD® Capture to Layout Interface

Library Manager 또는 Layout을이용하여사용할 Footprint를셋팅한다.Step 2
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OrCAD® Capture to Layout Interface

Footprint 입력을완료한후 ECO 아이콘을실행하면 PADS Layout의 Design Data가생성된다.Step 3



- 56 -www.intercad.co.kr

3

OrCAD와 PADS Layout의 Cross Probing

OrCAD 회로도에서 Symbol, Nets를선택하면 PADS Layout에서선택된다.

Multi Selection 및 Move Selected 기능지원

Union 메뉴에서 Cross Probing 기능을 Check한다.
OrCAD 회로도에서 Symbol을선택하면 PADS Layout의해당 Symbol이선택된다.

Example

[Window 작업표시줄]

OrCAD® Capture to Layout Interface
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4

PADS Layout 정보(Footprint/Ref변경/부품좌표)를 OrCAD로적용

Layout 부품정보를 OrCAD 회로도에업데이트할수있는 swp 파일을생성하는기능으로 Layout의
Reference 변경, Geometry, Location정보를 OrCAD Part의 Property에업데이트할수있다.

OrCAD® Capture to Layout Interface

PCB Package: OrCAD Property의 PCB Package항목에
Decal정보가입력된다.

PCB Footprint: OrCAD Property의 PCB Footprint항목
에 Decal정보가입력된다.

CoWork Program > File > Back Annotate를실행한후 Back Annotate 항목을선택한다.Step 1

OK 버튼을실행하면해당 Design의 swp파일이생성된다.
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OrCAD® Capture to Layout Interface

Step 2 OrCAD Capture > Tools > Back Annotate를실행한다.

CoWork에서생성한 SWP파일을적용한후 “확인”버튼을
실행하면 Back Annotate 된다.

Step 3 Back Annotate를완료한후 “Edit Object Properties”을실행해보면 Back Annotate한 Property를
확인할수있다.
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interCAD™ CoWork For PADS Layout

OrCAD를이용한 PADS Layout Data 생성
OrCAD 회로변경내용 PADS Layout 업데이트
PADS Layout 임의추가한부품 ECO 제외
PADS Design 정보 OrCAD로 Back Annotate

OrCAD® Capture to Layout Interface

OrCAD를이용한
PADS Layout Data 생성

OrCAD 회로변경내용
PADS Layout 업데이트

PADS Layout 임의
추가한부품 ECO 제외

PADS Design 정보
OrCAD로 Back Annotate

http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_chn.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_chn.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_mechanical.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_mechanical.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_back.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_back.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_chn.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_back.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_pads_mechanical.swf
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5

CoWork을이용한 Mentor Board Station Layout Data 생성

OrCAD에서출력한 Mentor용 Netlist를이용하여 Layout Data를생성할수있다.

CoWork DRC를통하여 OrCAD Netlist에또는 Build 오류를검사할수있다.

Librarian을실행한후 CoWork > Import Component > From OrCAD을이용하여 OrCAD 
ONL파일을 Open한다.

OrCAD® Capture to Layout Interface

Step 1
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OrCAD® Capture to Layout Interface

CoWork > Active Catalog를이용하여 Footprint를등록한다. Step 2
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Footprint 입력을완료한후 Build PCB를실행하면 Mentor Layout의 Design Data가생성된다.

OrCAD® Capture to Layout Interface

Step 3

Step 4 Design을저장한후 Layout을실행하여
배치/배선을하면된다.



- 63 -www.intercad.co.kr

6

OrCAD와 Mentor Board Station Layout의 Cross Probing

OrCAD 회로도에서 Symbol, Nets를선택하면 Mentor Board Station Layout에서선택된다.

Multi Selection 및 Move Selected 기능지원

Union 메뉴에서 Cross Probing 기능을 Check한다.
OrCAD 회로도에서 Symbol을선택하면 Mentor Layout의해당 Symbol이선택된다.

Example

[Window 작업표시줄]

OrCAD® Capture to Layout Interface
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7

Mentor Board Station Layout 정보(Footprint/Ref변경/부품좌표)를 OrCAD로적용

Layout 부품정보를 OrCAD 회로도에업데이트할수있는 swp 파일을생성하는기능으로 Layout의
Reference 변경, Geometry, Location정보를 OrCAD Part의 Property에업데이트할수있다.

OrCAD® Capture to Layout Interface

PCB Package: OrCAD Property의 PCB 
Package항목에 Decal정보가입력된다.

PCB Footprint: OrCAD Property의 PCB 
Footprint항목에 Decal정보가입력된다.

Layout > CoWork > Back Annotate를실행한후 Back Annotate 항목을선택한다.Step 1

OK 버튼을실행하면해당 Design의 swp파일이생성된다.
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OrCAD® Capture to Layout Interface

Step 2 OrCAD Capture > Tools > Back Annotate를실행한다.

CoWork에서생성한 SWP파일을적용한후 “확인”버튼을
실행하면 Back Annotate 된다.

Step 3 Back Annotate를완료한후 “Edit Object Properties”을실행해보면 Back Annotate한 Property를
확인할수있다.
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Mentor Design 정보
OrCAD로 Back Annotate

interCAD™ CoWork For Mentor Board Station Layout

OrCAD를이용한 Mentor Layout Data 생성
OrCAD 회로변경내용 Mentor Layout 업데이트
Mentor Design 정보 OrCAD로 Back Annotate

OrCAD® Capture to Layout Interface

OrCAD를이용한
Mentor Layout Data 생성

OrCAD 회로변경내용
Mentor Layout 업데이트

http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc_back.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc_back.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc.swf
http://www.intercad.co.kr/movie/loding_movie.html?file=/movie/cowork/swf/cowork_mgc_chn.swf
http://www.intercad.co.kr/movie/loding_movie.html?file=/movie/cowork/swf/cowork_mgc_chn.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc.swf
http://www.intercad.co.kr/movie/loding_movie.html?file=/movie/cowork/swf/cowork_mgc_chn.swf
http://www.intercad.co.kr/movie/movie_view.html?file=/movie/cowork/swf/cowork_mgc_back.swf
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감사합니다 !
기술지원

담당자: 오승석대리
E-mail: support@intercad.co.kr
Tel     : 031-786-0123

mailto:support@intercad.co.kr
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